WordPress网站更新提示429错误,是怎么回事?

XDD 发布于 4星期前 分类:建站知识

最近网站更新Wordpress后台版本或升级插件,经常出现429 too many requests错误,是为什么呢?应该怎么处理呢?

1个回复

  • 白天

    Wordpress网站更新后台版本和升级插件出现“429 Too Many Requests”错误,其实已经持续相当长一段时间了,最开始出现错误的时间应该是在wordpress推出5.3版本的时候。

    至于出现 “429 Too Many Requests”错误的原因,白天在网上看了很多解释,个人认为比较有说服力的原因是这样解释的:

    WordPress提示“429 Too Many Requests”原因

    1. 近几日有大陆的流量对 wordpress.org 发起猛烈攻击。
    2. 攻击导致其官网CDN面向大陆的反代服务器Nginx针对该域名自动停止。
    3. 官网有的爱好者并不知道面向大陆的CDN所处情况,他们自己能访问所以认为没问题。
    4. 解决该问题需要找到 automattic 管理官网的高层,专门为来自大陆的攻击给官网增加CC防御。
    5. 所以并不是 wordpress 官网主动封锁了大陆访客,而是 automattic 为官网购买的CDN服务器面向**的停摆了。
    6. 目前为止都是去无权管理 wordpress 官网的用户论坛反馈,自然找不到想要的答案。

    以上解释总结起来就是:因大陆流量对Wordpress攻击,导致Wordpress对国内屏蔽了。

    考虑到出现“429 Too Many Requests”的时间已经很久了,在还未恢复正常访问的情况下,该怎么处理呢?白天给大家推荐两种方法:

    方法一:迅雷下载

    找到worpress.org提供的插件或wordpress版本下载地址,使用迅雷即可下载。具体操作白天就不演示了,懂的都懂。

    方法二:翻墙

    鉴于wordpress.org屏蔽了国内,但国外是正常的,所以可以使用翻墙软件wordpress.org去下载插件或主题,然后再通过FTP或Xshell上传到自己的服务器上去。

    温馨提示:如果没有翻墙软件,又想要更新Wordpress后台版本或插件的话,可以在《更新WordPress 5.3版本时提示too many request 429错误解决方法》一文下面留言,白天可以代下载。